Calma! Não é uma falha no Moodle. É que em dezembro de 2018 se encerrou suporte de segurança às versões 5.6 e 7.0 do PHP (linguagem de programação utilizada para executar o Moodle) e aplicações que utilizam essas versões estão sujeitas a vulnerabilidades que não receberão correções.

Cerca de 62% dos sites na Internet utilizam o PHP 5.6, lançada em 2014, inclusive instalações Moodle com versões abaixo de 3.2 quando foi adicionado o suporte ao PHP 7.1. A partir da versão 3.4 do Moodle é exigido a versão 7.0 do PHP e há compatibilidade com as versões 7.1 e 7.2 do PHP que terão o suporte encerrado em dezembro/2019 e novembro/2020, respectivamente.

Se você usa uma versão igual ou inferior ao PHP 7.0 recomenda-se que faça a migração para versão com suporte ativo e evite problemas de segurança do seu ambiente Moodle.

Para saber qual versão do PHP sua instalação está usando navegue em Administração do site > Servidor > PHP info. A versão será apresentada no início da página.

Precisa de ajuda? Oferecemos serviços hospedagem em Moodle e suporte às atualizações do Moodle.

Entre em contato e conheça nossas soluções.

Quer saber mais sobre o suporte às versões do PHP? Veja no site oficial as versões suportadas: http://php.net/supported-versions.php.